OSDev.org

The Place to Start for Operating System Developers
It is currently Mon Sep 16, 2019 10:20 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Wed Oct 20, 2004 11:00 pm
Posts: 5
Location: New Zealand
Awesome site.
Keep up the good work, Chase.

Bug: 'members' under 'Who's Online' on the left, after clicking on a username, it shows the REAL email address, not the fake one.
(I have changed my profile, as i really want to keep that address spam-free.)

EDIT:
Bug 2:
On posting:
"Click Here to view your message

Click Here to return to the forum"

First 'Here' is a link, second one isn't


Last edited by Ytinasni on Thu Oct 21, 2004 11:00 pm, edited 3 times in total.

Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline
Site Admin
User avatar

Joined: Wed Oct 20, 2004 10:46 pm
Posts: 665
Location: Texas
Thanks for the bug reports! I'll fix those this weekend.


Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Wed Oct 20, 2004 11:00 pm
Posts: 5
Location: New Zealand
Bug n+1: Posts without any replies have
"Page 1 of 0"

Bug n+2: The 'Themes' do nothing at all.


Last edited by Ytinasni on Thu Oct 21, 2004 11:00 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline
Site Admin
User avatar

Joined: Wed Oct 20, 2004 10:46 pm
Posts: 665
Location: Texas
I've got the other themes turned of because I'd need to edit the other ones if I want to allow them to be used on OSDev.org. I guess it's a bug that you're still allowed to choose if they are turned off.....


Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline
Site Admin
User avatar

Joined: Wed Oct 20, 2004 10:46 pm
Posts: 665
Location: Texas
I saw your test. Seems like any page that only has one message gets the total page count wrong(-1).


Last edited by chase on Thu Oct 21, 2004 11:00 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Wed Oct 20, 2004 11:00 pm
Posts: 5
Location: New Zealand
Page 2 of 1

happens on the first post of the second page (forums show 2 pages correctly, just the counter at the bottom of the page is broken)

And some requests:

Could you please make the posts-per-page higher, or per-user? ATM, its kinda short.

Also, some smileys might brighten up the place a bit :)

Edit:
Bug: The 'delete post' feature is only availiable for my last post in any topic.
Edit 2:
i cannot delete anything if the last post is not mine

And, if i click reply, the last post is deleted, then i click submit, i get an error saying ${bb.No_such_Post}

Edit 3:
bug: The time is wrong. I have my 'Time Zone offset' set to my local time (GMT +12) and it is ~1:00 AM (Oct23) here, but the forums show it as ~5:00 AM (Oct 22). Looks like you're losing 20 hours somewhere.

"All times are GMT" <- No they aren't


Last edited by Ytinasni on Thu Oct 21, 2004 11:00 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Thu Oct 21, 2004 11:00 pm
Posts: 3
Quote:
Bug: 'members' under 'Who's Online' on the left, after clicking on a username, it shows the REAL email address, not the fake one.
(I have changed my profile, as i really want to keep that address spam-free.)


If you go in "My Account>Change your info", you have to uncheck "View real email".

It shouldn't be checked by default or asked at the registration stage. I will fix this (make it uncheck by default) in the Nukes repository, Chase will probably update this website.

Thanks to you for so good feedbacks, we are missing that a lot.

Good luck to Chase. I will keep looking into that forum for Nukes bugs.

Thomas. (Nukes contributor)


Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Thu Oct 21, 2004 11:00 pm
Posts: 3
I fixed the email stuff.

The behavior is like this now:
If you set up a fake email at the registration, that's the one that will be public. If you don't then the real email will be displayed.

You can always change using the profile setting afterwards. (For the people who already registered that's the way to do it)


Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Thu Oct 21, 2004 11:00 pm 
Offline

Joined: Wed Oct 20, 2004 11:00 pm
Posts: 5
Location: New Zealand
Ah, so that was my fault :\

Cant believe i missed that....

Good to see that no-one is perfect. (as much as i would like to be...)


Top
 Profile  
 
 Post subject: Re: GJ Chase! and a bug.
PostPosted: Sat Oct 23, 2004 11:00 pm 
Offline

Joined: Thu Oct 21, 2004 11:00 pm
Posts: 3
Was not your fault, the default setting was wrong. It is good that you saw it and told us.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group