OSDev.org

The Place to Start for Operating System Developers
It is currently Thu Feb 22, 2024 10:36 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: I keep getting logged out
PostPosted: Mon Jan 15, 2024 3:57 pm 
Offline
Member
Member

Joined: Tue Apr 03, 2018 2:44 am
Posts: 387
When I log in, and check "Log me on automatically each visit", I keep getting logged out regardless.

There seems to be no rhyme nor reason to it, it doesn't seem time based, and it can happen in short order (on the order of minutes.)

Which means the first version of this message wasn't actually submitted, because I was logged out while I wrote it, and I lost the original text! (this is actually the third attempt at this single submission!)

This never used to happen. It seems it started after an outage a couple of years ago, which I suspect was the one reported here:

https://www.reddit.com/r/osdev/comments ... orum_down/

So I wonder if it's a flag on the forum software (phpBB?) that's not been restored?


Top
 Profile  
 
 Post subject: Re: I keep getting logged out
PostPosted: Mon Jan 15, 2024 6:05 pm 
Offline
Member
Member

Joined: Mon Mar 25, 2013 7:01 pm
Posts: 5043
The last time I heard of someone having this kind of issue, it was caused by a broken add-on interfering with session cookies. Have you tried disabling your browser add-ons?


Top
 Profile  
 
 Post subject: Re: I keep getting logged out
PostPosted: Mon Jan 15, 2024 6:39 pm 
Offline
Member
Member

Joined: Tue Apr 03, 2018 2:44 am
Posts: 387
Octocontrabass wrote:
The last time I heard of someone having this kind of issue, it was caused by a broken add-on interfering with session cookies. Have you tried disabling your browser add-ons?


Food for thought. I'll investigate by trying Firefox in troubleshooting mode.

The reason I thought it was related to the server software is I distinctly remember that outage being the trigger for the change in behaviour.

But it could be a coincidence and a false association.


Top
 Profile  
 
 Post subject: Re: I keep getting logged out
PostPosted: Tue Jan 23, 2024 7:01 pm 
Offline
Member
Member

Joined: Tue Apr 03, 2018 2:44 am
Posts: 387
thewrongchristian wrote:
Octocontrabass wrote:
The last time I heard of someone having this kind of issue, it was caused by a broken add-on interfering with session cookies. Have you tried disabling your browser add-ons?


Food for thought. I'll investigate by trying Firefox in troubleshooting mode.

The reason I thought it was related to the server software is I distinctly remember that outage being the trigger for the change in behaviour.

But it could be a coincidence and a false association.


FYI, I currently think this is the Live Marks:

https://github.com/nt1m/livemarks/

Enabling this again logged me out within minutes, having been logged in for days.


Top
 Profile  
 
 Post subject: Re: I keep getting logged out
PostPosted: Wed Jan 24, 2024 12:51 am 
Offline
Member
Member
User avatar

Joined: Thu Aug 11, 2005 11:00 pm
Posts: 1109
Location: Tartu, Estonia
This is an interesting observation, especially since you mentioned Firefox and session cookies.

I have a similar issue that I was getting logged out here and from another forum some time ago using Firefox and I still don't know why. I tried to investigate the issue by opening the developer toolbar, network view, before navigating to those forums, to see what data is actually transmitted when I get logged out, but the problem did not occur while I did that. So I thought that maybe it was an issue with a Firefox version I had used in the meantime that was now fixed by an update, and so I stopped investigating. But then when I went to the forums again, I got logged out again (and since this time I had the toolbar closed, I did not see the network traffic, so I still got no clue why). So I started investigating again, keeping the toolbar open and waiting for being logged out again, but it hasn't occurred since then, and so I still have no data of such an event. All I saw in the developer toolbar was the correct transmission of cookies and getting logged in. This looks like a Heisenbug to me.

If you have any progress to share or ideas what to test I'd be happy to try those out. I don't use Live Marks, but maybe some other addon that I use interfaces with Firefox in a similar way to trigger this behavior.

_________________
Programmers' Hardware Database // GitHub user: xenos1984; OS project: NOS


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group