OSDev.org

The Place to Start for Operating System Developers
It is currently Wed Aug 12, 2020 5:48 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Mobius 23rd November 2003
PostPosted: Tue Dec 09, 2003 4:47 pm 
Since I got here first, I'll start things off :).

http://www.themobius.co.uk/sdk/mobius-f ... -23.img.gz

(Note that I use release dates for minor releases, not version numbers -- the next full release will be release 5, and it will be big!)

Some of you have already tested this disk image in the old thread. I'm receiving reports that it's failing to boot in VMware. It's known to crash with 64MB RAM, which is strange, because I might have expected it to crash with much more installed (like 512MB).

Anyway, I'd appreciate it if you could:
1) Boot it wherever. VMware would be useful.
2) If you get a crash, you should be dumped into the kernel debugger. When you're there, you should see a faulting CS:EIP, followed by a fault address, a register dump, and a stack dump. Please type:
pfn
boot
pte <fault address - top of the screen, or CR2 value>
Then it would be great if you could post a screenshot of this so I can look at it. The debugger is running in text mode at this point, so a text copy (in Bochs or Virtual PC is enough) would be easiest.

Thanks! If I can prove that this crash happens the way I think it does in VMware, I'll release an image which works better, with a few more goodies :).


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Tue Dec 09, 2003 5:12 pm 
Offline
Member
Member
User avatar

Joined: Fri Oct 22, 2004 11:00 pm
Posts: 1076
ok. ran the commands. here is your screenshot

[attachment deleted by admin]

_________________
-- Stu --


Top
 Profile  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Tue Dec 09, 2003 5:26 pm 
Offline
Member
Member
User avatar

Joined: Fri Oct 22, 2004 11:00 pm
Posts: 1076
heres the serial port debug msg;

i386InitSerialDebug: kernel debugger running on port 3f8
bottom = 32496, low = 256, num = 32496, mem_pages = 0043b000..004b9f00
Created thread kernel/1 (KeStartupThread)
Created thread kernel/2 (DevLoaderThread)
Created thread kernel/3 (FsFileCloserThread)
Created thread kernel/4 (MemZeroPageThread)
Created thread /System/Boot/monitor.exe/5 (main)
Thread 1 exited with code 0

_________________
-- Stu --


Top
 Profile  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Tue Dec 09, 2003 5:32 pm 
Thanks for the info df. It should give me plenty to go on.

I thought it was a problem with the initialisation of my physical memory manager, but now I'm not so sure. The crash seems to be happening when freeing the kernel stack used by the startup thread (thread 1). The OS itself is apparently booting OK up til this point.

PS: df used a slightly later version of Mobius for this. If you want, try http://www.themobius.co.uk/sdk/mobius-f ... -09.img.gz, which I made tonight. Tonight's image is a little cooler when you get in, but less stable :).


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Tue Dec 09, 2003 5:46 pm 
OK, a quick update, and hopefully a bug fix (!)...

1. Download http://www.themobius.co.uk/sdk/mobius-f ... -09.img.gz
2. Download http://www.themobius.co.uk/sdk/kernel-2003-12-09.exe
3. Copy the kernel-2003-12-09.exe to BOOT\KERNEL.EXE on the disk image (either on a real floppy, or using mtools, Winimage or the Linux loopback device)
4. Try it out!

I uploaded the kernel EXE separately because I found a bit of code which might be causing this error and I couldn't be sure that I could upload all 1MB of the disk image again reliably. It's a hard life with a modem connection... :(


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Wed Dec 10, 2003 9:20 pm 
With the injected kernel:

Bochs 2.02:

Boots fine (Nice loading screen) to a blue background and a moveable square. Managed to get the hello world program running, and the terminal. Type 'ls' into the terminal (Didn't know what else to do) and got dropped to the debugger. If I tried double clicking anywhere I also got dropped to the debugger. Output from a double click version:

[pre]
Thread /Mobius/winmgr.exe/13: Interrupt 14 at 1b:0062c1de: 000320a2
Page fault: protection violation writing in user mode
---- Context at dffdbfa4: ----
EAX 00000008 EBX bbbbbbbb ECX 00000008 EDX 00000082
ESI 00031e28 EDI 000320a2 EBP 7fbffcbc
CS 0000001b DS 00000023 ES 00000023 FS 00000033
GS 00000023 SS 00000023 CR2 000320a2
EIP 0062c1de eflg 00010202 ESP0 dffdbfa8 ESP3 7fbffcb4
ebp Return To Parameters
0062c1de
7fbffcbc 004088a3 (000320a2, 00031e28, 00000008) /Mobius/winmgr.exe
7fbffcdc 00407bcc (00030588, 7fbffd64, 7fbffd14) /Mobius/winmgr.exe
7fbffdcc 004058b1 (0002e390, 00030588, 00000000) /Mobius/winmgr.exe
7fbffedc 00406459 (80000004, 000308b0, 000308c0) /Mobius/winmgr.exe
7fbfff4c 00401b91 (000307f8, 0000017c, 7fbfff80) /Mobius/winmgr.exe
7fbfffdc 0060292b (0002fb60, 00000001, 00000000) /Mobius/libsys.dll
7fbffffc 00000000 (00000000, 00000000, 00000000) (unknown)
Mobius Debugging Shell
> 77
> pfn
mem_pages from d0000000 to d0020000 (0043b000 to 0045b000)
Free list:
first = 4294967295 (fffff000), last = 4294967295 (fffff000), count = 0 (0KB)

Free low list:
first = 34 (00022000), last = 11 (0000b000), count = 128 (512KB)
Zero list:
first = 1773 (006ed000), last = 1407 (0057f000), count = 6457 (25828KB)
> pte 000320a2
0x000320a2 => 0x0061b000: PwUtnAdg
[/pre]

Real hardware (Celeron 800mhz, GeForce2FX):
Doesn't reach the boot screen. Couldn't get a screen capture so I just wrote down some of the details.

[pre]
Assertion field: rtlsup.c, line 457
diff < 0x01000000
Thread kenrel/2: interrupt 3 at 8:c00181a8:00000000
[/pre]

Then there's a context dump. EIP:c00181a8

Then there's what looks like a trace back giving value for vesa.kll, video.drv, kernel.exe and (unknown).

Guess it's something to do with my gfx card. I'll drop it on my crash machine sometime (Trio64 gfx card) and see if that make a difference.

Hope that helps.


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Thu Dec 11, 2003 5:32 am 
Bochs: Good that it boots and you can actually see something of the GUI. The GUI is still really early on in development, so some crashes are expected. There's also an unfortunate bug in the shell which crashes on an invalid command :-\. Try dir or help.

Real hardware: Good that it doesn't boot :) as it gives me a change to fix another bug. This looks like something is trying to allocate more than 1MB of memory at once. Although this is valid, it usually indicates an incorrect size somewhere. You're right, this looks like a VESA problem. How much memory do you have on your card?


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Thu Dec 11, 2003 12:39 pm 
Offline
Member
Member

Joined: Wed Oct 18, 2006 11:59 am
Posts: 1600
Location: Vienna/Austria
I have tested the version of 9.12.2003 with injected kernel.

testmachine: athlon xp 1700+, asus mobo, nvidia riva tnt2 3d graphics card with 32 mb vram, 512 mb system ram.

I reach "starting m?bius" then there come 2 boxes indicating some progress, then it drops me to the mobius debugging shell.

following relevant fields:

thread kernel/4: Interrupt 14 at 8:c0002eb5:d01ff004
eip: c0002eb5, eflag: 0x10016 esp0: dfff6f4c,esp3: 0xc0024000, cr2:0xd01ff004

now, i gonna start it in the bochs 2.0.2: boots up fine - the initialization screen is really cool: blinking symbols and sorts - nice gadgets for the eye.

Now, I've managed to start the gconsole: it opens header, frame, but the text control itself remains empty. But upon doubleclicks I don't get any faults. It is a wee bit slow in the bochs. but blue illusion is slow in the bochs too, so this can't be taken as a measure. On invoking the gconsole a second time, I get a kind of fault. I'll try and get some screenshots out of the bochs now.

this screenshot 's been taken prior to invoking the gconsole. upon clicking at menu item gconsole mobius tried to start it, attempted to rebuild the screen and then suddenly crashed into a debug session. I can't deliver the contents for it is utterly scrambled in the bochs. but as far as I see, it is a page fault in winmgr.exe.

hope this helps

continue with that cool thing.

[attachment deleted by admin]

_________________
... the osdever formerly known as beyond infinity ...
BlueillusionOS iso image


Top
 Profile  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Thu Dec 11, 2003 3:35 pm 
Tim Robinson wrote:
How much memory do you have on your card?


32mb.

Took another look in bochs. Dir and help work fine as far as I can see (23*6 window, yuck, could be a Bochs thing). Haven't run it on older hardware yet, had some stuff to do today (Hate shopping :().

***

Note to bochs users: Use VGABIOS-lgpl-latest instead of the elpin version. Otherwise you'll find yourself looking at only a tiny portion of the screen.


Top
  
 
 Post subject: Re:Mobius 23rd November 2003
PostPosted: Thu Dec 18, 2003 10:05 am 
Offline
Member
Member
User avatar

Joined: Wed Oct 18, 2006 2:31 am
Posts: 5964
Location: In a galaxy, far, far away
works fine in BOCHS for me, except that there are weird color artifacts when the console scrolls and that the keyboard mapping for digits (both keypad which maps everything to '?' and the alphanumeric digits row) aren't correct.

the console and programs are pretty slooow too, but i guess this is due to the emulator ...

_________________
Image May the source be with you.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group