OSDev.org

The Place to Start for Operating System Developers
It is currently Sat Jul 20, 2019 8:26 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: AHCI Real Hardware problem
PostPosted: Wed May 29, 2019 6:33 am 
Offline

Joined: Tue Mar 05, 2019 12:44 pm
Posts: 9
Hey, thanks a lot for your awesome work, OSDev !

I'm following https://wiki.osdev.org/AHCI, and I'm trying to read disk sectors now, and I understand the given code at 70%.
Paging is enabled and I identity-mapped all these AHCI spaces as I needed, fixing a lot of the page faults I was initially getting.
On Qemu I can and I'm very happy with the result, I was able to read 3 sectors without a problem;
however on real hardware (my Toshiba Satellite Pro NB10-a-125), about the command slots which are gathered at this line (in find_cmdslot):
Code:
uint32_t slots = (port->sact | port->ci);

This combination returns 0, which means there are no available command slots on my AHCI Sata hardware (PCI Class+Interface mode: 1, 6, 1 = AHCI SATA).
Obviously this prevent any disk read, this is annoying.

I have no idea how to understand why aren't there any slot available...
Can someone help me on this ?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: AssemblyDavid and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group