OSDev.org

The Place to Start for Operating System Developers
It is currently Tue Aug 20, 2019 2:34 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: VirtualBox: SMBIOS Type 3 wrong format
PostPosted: Wed Apr 17, 2019 1:03 am 
Offline

Joined: Sun Apr 14, 2019 12:19 am
Posts: 4
Hello,

I'm new in this forum. Before asking my question, I must said that it's very interessting to learn how OS works.
I'm living in France and interesting by low level programming languages. Sorry by advance for my poor English.

So this is my question:

Reading SMBIOS with WMware or QEMU is OK. While reading SMBIOS with VirtualBox, at Type 3 I've this issue.
Attachment:
SMBIOS_3.png
SMBIOS_3.png [ 26.22 KiB | Viewed 338 times ]

As you see SMBIOS version is 2.5 with 10 entrys. Type 0, 1, 2 have been read correctly before.

In the documentation Type 3 > 2.1, len is supposed to be 0Dh. So it's OK we have the minimum (in blue).
After (in green) the string terminated with 0 and the second 0 as expected to terminate the structure.

So after, in QEMU or WMvare, we will found type 4 (Processor Information). Here not, we have Type 126 and until end of structure other with the Type 128 that doesn't exist in documentation.
So I think that here the table is incorrect. You can see in the memory dump what I get.

What's wrong?


Top
 Profile  
 
 Post subject: Re: VirtualBox: SMBIOS Type 3 wrong format
PostPosted: Wed Apr 17, 2019 12:26 pm 
Offline
Member
Member
User avatar

Joined: Sun Sep 19, 2010 10:05 pm
Posts: 1065
I'd have to do a little more digging to read the actual data, but I can tell you that I'm getting the same list of tables that you are getting when running in VirtualBox 6.0.

10 Tables
0, 1, 2, 3, 126, 126, 126, 11, 128, 127

I'll look through the string data and see if I'm getting the same results there.

EDIT: According to Wikipedia, anything over 127 is reserved for OEM specific data.

https://en.wikipedia.org/wiki/System_Management_BIOS

EDIT2: I found this bug in the VirtualBox bug tracker:
https://www.virtualbox.org/ticket/17696

Looks like it is a known issue, known at least for 10 years, and so low priority that no one has bothered fixing it. So you can probably safely ignore it, unless you need that table 4 to exist for some reason. VirtualBox is open source, so you could probably fix it for them, if you wanted...

_________________
Project: OZone
Source: GitHub
Current Task: DOSBox Compatibility
"The more they overthink the plumbing, the easier it is to stop up the drain." - Montgomery Scott


Top
 Profile  
 
 Post subject: Re: VirtualBox: SMBIOS Type 3 wrong format
PostPosted: Thu Apr 18, 2019 1:20 am 
Offline

Joined: Sun Apr 14, 2019 12:19 am
Posts: 4
Thank you for your reply.

So it's a know bug since 10 year :) It's for testing my code, so I'll stop to use VirtualBox for this purpose. WMvare and QEMU works fortunally.

PS: I've not the time to fix the bug from VirtualBox code for the moment.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: quadrant and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group